summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPeter Ludikovsky <peter@ludikovsky.name>2016-09-08 17:13:07 +0200
committerPeter Ludikovsky <peter@ludikovsky.name>2016-09-08 17:13:07 +0200
commit445aee0ba17e7d9c803187f233428802d3721374 (patch)
tree84883669685feb614f8976d60865410e68a9b827 /debian/rules
parent64f7a9614568e3d42bcddc4f523dfc691f360ca8 (diff)
* Debianized everythingHEADmain
* Corrects/improves SystemD Unit * Disabling logging to /var/log
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1395143
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@ --with-systemd
+
+# debmake generated override targets
+# This is example for Cmake (See http://bugs.debian.org/641051 )
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
+
+
+
+